PHP: Hypertext Preprocessor, commonly referred to as PHP, is a popular open-source programming language, which is used to set up dynamic websites with interactive elements such as bulletin boards, school websites or community portals. In comparison with static HTML-based websites, a PHP-powered website can display different content to each visitor under the same page URL. Considering the fact that PHP-based Internet apps can be managed via a Control Panel, which you can log on to using any Internet browser, you will not need any programming skills or practical experience whatsoever to maintain a PHP website. The fact that 100s of millions of sites all over the globe are created with PHP is indicative of the language’s popularity and simplicity of use. You only ought to confirm that the web server on which your site is hosted supports the same version of PHP as the one that you used whilst developing the site.

PHP 4, PHP 5 and PHP 7 Support in Hosting

If you order a hosting plan from our company, you will never have to speculate if your websites are compatible with the web hosting environment, since multiple versions of PHP are available on our servers for the sake of your convenience. The Hepsia Control Panel will permit you to choose PHP 4, PHP 5 and PHP 7 with only one mouse click and in case you want to change the current version, the update will be applied instantaneously. In this way, many years of work on sites created with an older PHP version won’t go down the tubes. Our web hosting platform will even allow you to use a different version of PHP for each domain hosted in your account, which goes to say that you can run older and newer scripts simultaneously. Most hosting providers on the market offer support for one, sometimes for two PHP versions. In stark contrast with them, we are strongly convinced that you should be the one to pick the version that will be used by your own websites.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

If you have a website created using an older PHP version and you have committed time and effort into developing it, fixing security breaches and adding content, you’ll need a web hosting service that can support it, since the vast majority of hosting suppliers today offer support only for the most recent PHP version and abandon the previous versions. We, on the other hand, have decided to allow you to select the version that your own sites require. Our semi-dedicated service support PHP 4, PHP 5 and PHP 7, which means that you will be able to run both newer and older scripts without losing any manual modifications or misspending time and energy trying to make your websites compatible with the hosting environment. You can change the version via the Hepsia hosting Control Panel and such an update will apply to the whole account, but you will also have the ability to specify a different PHP version for each site hosted in your account using an .htaccess file.