Many licensed and some cost-free script-driven applications have protected program code, that isn't human readable. The concept behind this is to prevent the reverse engineering as well as the unauthorized use of such applications. Among the most popular encryption instruments used for this specific purpose is called Zend Guard and it's widespread due to the fact that it can be used to alter any PHP 4 or PHP 5 code. The only way for the protected files to run effectively on a web server after that is when one more instrument called Zend Optimizer is available. If you would like to work with any kind of paid web software which needs Zend Optimizer, you need to ensure that it is installed on the server where you will host your website. In addition, sites that need the instrument usually perform better due to the fact that their program code is already precompiled and optimized, and therefore it's executed more quickly.

Zend Optimizer in Hosting

When you acquire a hosting service from us, you are able to select the PHP version, that will be active for your account according to what your script applications require. You can activate Zend Optimizer with just a single click in the Advanced area of the Hepsia web hosting Control Panel for any of the versions that we offer - 4, 5.2, 5.3, 5.4 and 5.5. When you go to this section, you'll be able to employ a small tool which will allow you to handle the php.ini file for the account and activate or deactivate PHP extensions through On and Off buttons, therefore you will not need any previous experience because enabling Zend Optimizer will be as simple as clicking a button. More experienced users will be able to do the same thing by adding a php.ini file with the needed program code in a particular domain folder. In case you need any help to activate the tool, you'll be able to contact our tech support team anytime.

Zend Optimizer in Semi-dedicated Servers

Zend Optimizer is installed on all of the servers that comprise our cluster hosting platform, therefore you can use it for all your script-driven apps with all of our semi-dedicated server plans. It is available all the time even when you switch the PHP version for your account as our feature-rich platform will allow you to choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing your version and activating Zend Optimizer for the new one takes a few clicks in the PHP Configuration area of the Hepsia website hosting Control Panel which is used to take care of the semi-dedicated accounts. Furthermore, you can even employ a different release of PHP and activate or deactivate Zend for each individual site that you host in your account. You can do this by employing a php.ini file in a domain folder with several lines of program code in it. In case you don't have previous experience and you are not sure how to do that, our 24/7 technical assistance can help you.